Корзина заказа

ФИО
Ваш почтовый адрес
Ваш телефон
Ваша эл. почта


Main

  • Главная
  • Рабочий план
  • Занятие 1
  • Занятие 2
  • Занятие 3
  • Занятие 4
  • Занятие 5
  • Занятие 6
  • Занятие 7
  • Занятие 8
  • Занятие 9

Учебно-методический комплект по программированию для студентов, обучающихся по специальности 05020252 "ИНФОРМАТИКА"

часть I

Разработан

преподавателем

информатики

Авдеевой Е.В.

2007 год

НАЦИОНАЛЬНЫЙ ФОНД ПОДГОТОВКИ КАДРОВ. ИНФОРМАТИЗАЦИЯ СИСТЕМЫ ОБРАЗОВАНИЯ.
Сайт сделан по технологии "Конструктор школьных сайтов".


Main

  • Занятие 2
  • Занятие 3
  • Занятие 4
  • Занятие 5
  • Занятие 6
  • Занятие 7
  • Занятие 8
  • Занятие 9

Учебно-методический комплект по программированию для студентов, обучающихся по специальности 05020252 "ИНФОРМАТИКА"

часть I

Разработан

преподавателем

информатики

Авдеевой Е.В.

2007 год


Рабочий план

  • Занятие 5
  • Занятие 6
  • Занятие 7
  • Занятие 8
  • Занятие 9

Рабочий план учебного курса «ПРОГРАММИРОВАНИЕ»

3 курс

Раздел 1

Введение в программирование

Л

С

1

Введение. Общие сведения. Понятие синтаксиса языка. Структура программы.

2

Раздел 2

Язык программирования Pascal. Создание программ на языке программирования Pascal.

2

Организация данных, переменные. Обработка числовой информации. Управление экраном в текстовом режиме.

2

3

Линейная структура программы. Управление экраном в графическом режиме.

2

4

Ветвление в программе.

2

5

Разработка программ с ветвлением в алгоритмах.

2

6

Циклический алгоритм. Операторы цикла.

2

7

Основные алгоритмы циклической структуры

2

8

Разработка программ циклической структуры

2

9

Контрольная работа

2


Занятие 1

  • Занятие 8
  • Занятие 9

Тема: "Введение. Общие сведения. Понятие синтаксиса языка. Структура программы"

  1. Введение
    • Программное обеспечение персонального компьютера
  2. Общие сведения
    • Историческая справка
    • Основные понятия
  3. Структура языка Паскаль
  4. Структура программы
  5. Тест №1 "Проверь себя"
  6. Контрольный тест
  7. Самоподготовка


Введение

Введение

Запись алгоритма на языке ЭВМ называется программой.

Программирование — это научная дисциплина, которая изучает общие методы решения задач на ЭВМ, позволящие, постепенно расчленяя задачи на подзадачи, сводить их решение, к типовым алгоритмам.

Программным обеспечением (ПО) называют организованную совокупность программ постоянного употребления.

Различают три основные группы программ для компьютера: системное, прикладное программное обеспечение и инструментальные средства.

Системное программное обеспечение — программы, предназначенные для управления работой компьютера, объединения различных устройств вычислительной техники в единую вычислительную систему и выполнения работ, связанных с обслуживанием вычислительных машин.

Прикладное программное обеспечение — программы для решения класса задач в определенной области применения систем обработки данных.

Инструментальные средства (системы программирования) — это пакеты программ для создания или изменения программ.


Общие сведения

Общие сведения

Решение задачи начинается с ее математической постановки, включающей в себя широкий спектр вопросов, связанных с разработкой математических и физических моделей, выводом расчетных формул и т. п. За ней следует п роцесс программирования, начинающийся с составления алгоритма, который заключается в логическом описании процесса решения задачи и требует знания элементов математической логики, и заканчивающийся его записью на языке программирования.

Язык программирования – формальный язык, специально созданный для общения человека с компьютером, представляющий из себя систему обозначений, слов, букв, чисел. Система правил, определяющих допустимые конструкции языка программирования из букв алфавита называется синтаксисом.

Следующим является процесс отладки программы, который связан с выявлением:

  • синтаксических ошибок в тексте (неверно записанных операторов);

  • ошибок при выполнении программы (недопустимые математические действия, операции с числами, превосходящими предельные значения);

  • алгоритмических ошибок (неверно составлен или запрограммирован алгоритм).

Познакомимся с понятием структурного программирования.

Никлаус Вирт

Структурное программирование - это методология программного обеспечения, в основе которого лежит представление программы в виде структуры блоков, т.е. каждая программа представляет собой структуру, построенную из трех типов базовых конструкций: следования, ветвления и цикла.

Предложена такая методология Э. Дейкстойем и разработана профессором Цюрихского технологического института Никлаусом Виртом в 70-х годах XX века для обучения студентов.

Основные понятия

Действие - это то, что имеет конечную продолжительность и приводит к желаемому и совершенно определенному результату.

Объект – это то, над чем это действие совершается и по изменению состояния которого можно судить о результате этого действия.

Инструкция – описание действия с помощью некоторого языка или системы формул.

Процесс (вычисление) - действие, которое можно разложить на составные части. Если эти части во времени следуют строго друг за другом и никакие две части не выполняются одновременно, то процесс называется последовательным.

Программа - инструкция, описывающая процесс и состоящая из составных частей.

Исполнитель – то, что выполняет действия согласно заданным инструкциям.

Алгоритм – это система точных и понятных инструкций о содержании и последовательности выполнения конечного числа действий, необходимых для решения задачи.


Структура языка PASCAL

Структура языка PASCAL

Pascal - язык структурного программирования. Так назван в честь выдающегося французского математика и философа Блеза Паскаля (1623 — 1662).

Служебные (зарезервированные) слова

absolute, and, array, begin, case, const, constructor, destructor, div, do, downto, else, end, external, file, for, forward, function, goto, if, implementation, in, inline, interface, interrupt, label, mod, nil, not, object, of, or, packed, procedure, program, record, repeat, set, shl, shr, string, then, to, type, unit, until, uses, var, vertual, while, with, xor и другие.

Язык Pascal предназначен для описания вычислительного процесса решения задачи, в состав которой могут входить величины.

константы - данные, значения которых не изменяются в программе;

переменные - данные, могущие изменяться при выполнении программы;

Для обозначения имен констант, переменных, функций, процедур и модулей используются буквы и цифры, входящие в алфавит языка, и знак подчеркивания " _ ". Имена начинаются с буквы или знака подчеркивания " _ "и содержат до 63 значащих символов. Символ пробела в имени не допускается. Эти имена принято называть идентификаторами.

выражения - константы, переменные и обращения к функциям, соединенные знаками операций;

операторы - специальные символы и слова, выполняющие действия;

функции, процедуры и модули - отдельные программные блоки, имеющие имена и подключаемые к основной программе.

Типы величин

  • Целые величины могут быть отрицательными, положительными и 0.

Идентификатор | Диапазон представления чисел | Размер памяти | Название типа
Shortint | -128…127 | 1 байт | Короткое целое со знаком
Integer | -32768..32767 | 2 байт | Целое со знаком
Longint | -2147483648.. 2147483647 | 4 байт | Длинное целое
Byte | 0..255 | 1 байт | Короткое целое без знака
World | 0..65535 | 2 байт | Целое без знака

  • Вещественные величины - действительные числа. Существуют две формы записи вещественных чисел. Основная – с фиксированной точкой (дробная часть отделяется от целой десятичной точкой), и запись числа с порядком или экспоненциальная.

Идентификатор | Диапазон представления чисел | Размер памяти | Название типа | Количество цифр
Single | от 1,5*10-45 до 3,4*1038 | 4 байта | Вещественное одинарной точности | 7..8
Real | от 2,9*10-39 до 1,7*1038 | 6 байта | Вещественное | 11..12
Double | от 5,0*10-324 до 1,7*10308 | 8 байта | Вещественное двойной точности | 15..16
Extended | от 3,4*10-4932 до 1,1*104932 | 10 байта | Вещественное повышенной точности | 19..20

Операции над числовыми величинами

Операции | Действие | Тип операндов | Тип результата
Унарная
+ | Сохранение знака | Целый Вещественный | Целый Вещественный
- | Отрицание знака | Целый Вещественный | Целый Вещественный
Бинарная
+ | Сложение | Целый Вещественный | Целый Вещественный
- | Вычитание | Целый Вещественный | Целый Вещественный
* | Умножение | Целый Вещественный | Целый Вещественный
/ | Деление | Целый Вещественный | Вещественный Вещественный
Div | Целочисленное деление | Целый | Целый
Mod | Остаток от деления | Целый | Целый

  • Символьные величины (CHAR).

Значениями символьных величин являются символы из алфавита.

  • Строковый тип данных (STRING).

Значениями сстроковых величин являются последовательности символов из алфавита.

  • Булевские величины(BOOLEAN).

Булевским типом называют тип данных, представляемый двумя значениями True и False.

Таблица встроенных функций

Число p в Паскале - функция Pi

Таблица специальных функций

Таблица специальных процедур

Randomize - генератор случайных чисел

Случайное число от 0 до 1 - Random

Случайное число от 0 до N - Random(N)


Структура программы

Структура программы

Program name; {Заголовок программы}

Uses <модули>; {подключение стандартных и пользовательских библиотечных модулей}

Label <метки>; {описание меток}

Const <константы>; {определение констант}

Type <типы>; {определение типов}

Var <переменные>; {описание переменных}

<раздел процедур>; {описание процедур}

begin

<программа>;{операторы}

end.

Оператор ввода.

Read(<список>);

ReadLn(<список>);

Ввод – это передача информации от внешнего носителя в оперативную память для обработки. Список состоит из переменных допустимых типов данных. Значения из списка набираются на клавиатуре минимум через один пробел и высвечиваются на экране. После набора данных для одной процедуры Read нажимается клавиша Enter.

Оператор вывода

Write(<список>);

WriteLn(<список>);

Вывод – это передача данных из оперативной памяти на внешний носитель. Внешним носителем может быть терминал(экран), печатающее устройство, магнитный диск и др. устройства. В процедурах Write и WriteLn имеется возможность записи выражения, определяющего ширину поля вывода:

Write(X:6:2); - X выведется в формате с фиксированной точкой и под него будет отводиться 6 позиций, причем 2 из них займет дробная часть.


Тест №1

Тест №1

1. | Процедура ввода
 | WRITE
 | REAL
 | READ
 | FALSE
2. | Булевский тип величины
 | BOOLEAN
 | TRUE
 | REAL
 | INTEGER
3. | Раздел описания переменных
 | TYPE
 | VAR
 | CONST
 | INTEGER
4. | Определите тип константы ‘Pascal’
 | REAL
 | STRING
 | INTEGER
 | BOOLEAN
5. | Целочисленное деление
 | TRUE
 | DIV
 | MOD
 | FALSE
6.

Вычислить значение выражения:

SUCC(-5)

Ответ:

7.

Вычислить значение выражения:

–27 DIV 4

Ответ:

8.

Вычислить значение выражения:

9>5

Ответ:

9.

Определить тип результата, если i, j, k – целые числа.

i * j +k

Ответ:

10.

Чему равно значение переменной x после выполнения последовательности операторов?

a:=25;

b:=a-4;

x:=(a-b)*2-2;

Ответ: x=

11.

Чему равно значение переменной а?

x:=345;

a:=x mod 10 *( x div 100);

Ответ: a=

12.

Вычислить: 3* 7 div 2 mod 7 /3 – trunc(sin(1))

Ответ:


Тест №2

Контрольный тест

1. | Процедура вывода
 | WRITE
 | REAL
 | READ
 | FALSE
2. | Вещественный тип величины
 | BOOLEAN
 | TRUE
 | REAL
 | INTEGER
3. | Раздел описания типов
 | VAR
 | TYPE
 | CONST
 | INTEGER
4. | Определите тип константы 2.1 Е -02
 | REAL
 | STRING
 | INTEGER
 | BOOLEAN
5. | Остаток от целочисленного деления
 | TRUE
 | DIV
 | MOD
 | FALSE
6. Вычислить значение выражения

SUCC(5)

Ответ:

7.

Вычислить значение выражения

27 MOD 4

Ответ:

8.

Вычислить значение выражения

4 < 2

Ответ:

9.

Определить тип результата, i, j, k – целые числа.

i / j +5 * k

Ответ:

10. Чему равно значение переменной x после выполнения последовательности операторов?

x:=8;

y:=11;

x:=x * y + x;

Ответ:

11.

Чему равно значение переменной b ?

y:=963;

b:=y div 100 /( y mod 10);

Ответ:

12.

Вычислить: 24/ trunc (3.8) + succ(-3)- round(23/6)

Ответ:

Ваше имя:
Ваш e-mail:


Самоподготовка 1

Самоподготовка

Тема 1: "Этапы решения задач на ЭВМ"

И.Г. Семакин, А.П. Шестаков «Основы программирования», стр. 6-10

В.Б. Попов «Turbo Pascal для школьников», стр. 15-18

Вопросы:

  1. Перечислите основные этапы решения задач на ЭВМ.

  2. Что такое алгоритм?

  3. Какие существуют способы записи алгоритма?

Тема 2 "Интегрированная среда программирования"

Курс по программированию на Паскале, раздел "Введение в Паскаль"

В.Б. Попов «Turbo Pascal для школьников», стр. 21-44

Вопросы:

  1. Что такое языки программирования? Какова их классификация?
  2. Зачем нужны трансляторы?
  3. Чем компилятор отличается от интерпритатора?
  4. Перечислите основные файле среды программирования Паскаль.
  5. Перечислите основные компоненты окна редактирования среды программирования Паскаль.
  6. Как откомпилировать файл в среде программирования Паскаль?
  7. Как просмотреть результаты выполнения программы?


Занятие 2

Тема: "Организация данных, переменные. Обработка числовой информации. Управление экраном в текстовом режиме."

  1. Демонстрация интегрированной среды программирования
  2. Рекомендации по стилю программирования
  3. Арифметические выражения
  4. Логические выражения
  5. Пример разработки программы
  6. Управление экраном в текстовом режиме
  7. Тест №3 "Проверь себя"
  8. Контрольный тест
  9. Самоподготовка


Рекомендации

Рекомендации по стилю программирования:

  • G Не следует операторы программы писать сплошным текстом.

  • G Рекомендуется программу сопровождать комментариями, пояснениями назначения всей программы и ее отдельных блоков.

  • G Придерживаться принципа «Программирование сверху вниз», т. е. следует начинать с самой общей модели решения, постепенно уточняя ее до уровня отдельного блока.

Для проверки правильности функционирования программы выполняют тестирование – исполнение программы с использованием некоторого набора данных. Цель тестирования - выявить ошибки в программе. Для устранения ошибок в программе выполняют ее отладку. Для проведения отладки в интегрированной среде Borland Pascal используют трассировку программы, т.е. выполнение «по шагам» с остановкой в указанных точках. Для осуществления пошаговой отладки следует использовать функциональные клавиши:


Арифметические выражения

Арифметические выражения

Конструкция языка, задающая порядок выполнения действий над элементами данных, называется выражением. Выражение состоит из операндов над которыми производятся операции.

Арифметическим выражением называется выражение, составленное из операндов целого или вещественного типа и использующее только арифметические операции.

К арифметическим операциям относятся: сложение(+), вычитание(-), умножение(*), деление(/), деление нацело (DIV), вычисление остатка от деления (МОD).

Значения выражения вычисляется с учетом расставленных скобок и старшинства операций (приоритета). Ниже представлены операции в порядке убывания их приоритета:

NOT

*, /, MOD, DIV, AND

+, -, OR

<, <=, >, >=, <>, =

Операции одного и того же старшинства выполняются слева на право в порядке их появления. При выполнении арифметических операций над величинами только вещественного, а также вещественного и целого типов вырабатывается результат вещественного типа. Тип выражения определяется последовательным вычислением типов результатов всех операций, выполненных при вычислении значения выражения.

Целые числа в Паскале записываются в обычном виде, например: 0, +100,-56498.
Вещественные числа в Паскале представляются в одной из двух форм, которые называются: запись числа с фиксированной точкой и запись с плавающей точкой. Первая из них - это запись числа в виде целой и дробной частей, разделенных точкой, например: -3.15 , 0.1 , +23.0125.

Вторая форма - с плавающей точкой - это запись числа с мантиссой и десятичным порядком, разделенными латинской буквой E. Такая запись означает, что мантисса (которая может быть целым числом или вещественным числом в форме с фиксированной точкой) умножается на 10 в степени, задаваемой порядком (который всегда должен быть целым числом), например -18.7Е+3 , 2.123Е4, 2.34Е-2 , 6Е-1.

В языке программирования Паскаль запрещается запись вещественных чисел в виде .5 или 5. Их необходимо записывать как 0.5 и 5.0 соответственно. Если в записи числа содержится точка, то по крайней мере одна цифра ей должна предшествовать и следовать за ней.

Основным требованием к записи выражений в Паскале является размещение всех его элементов в одной строке (на одном уровне). В выражениях допускается использовать константы (неизменяемый объект программы), переменные (объект программы, который может изменять свое значение), операции ( + , - , / , * , . . . ) и функции.


Пример разработки программы

Пример разработки программы

Задача.

Подсчитать сколько потребуется банок с краской для покраски бака для бензина, имеющего форму цилиндра, радиус основания которого R, а высота H, если одной банки краски достаточно для покраски площади 236 кв.ед.

Математическая постановка задачи:

1. Исходные данные:

R – радиус цилиндра;

H – высота цилиндра;

S1 - площадь, которую можно покрасить 1 банкой краски.

Дополнительные переменные:

S - площадь поверхности бака;

OST - остаток площади, на которую не хватило краски;

BOOL - логическая переменная для проверки есть ли остаток площади.

2. Результат:

B - число банок необходимых для покраски

3. Метод решения задачи:

Последовательные вычисления по формулам:

S=pR2 + 2pR H; {площадь поверхности бака}

B= S DIV S1; {число банок необходимых для покраски}

Ost= S MOD S1; { остаток площади, на которую не хватило краски }

Bool=(Ost <> 0) {Если остаток от деления , то число банок увеличивается на 1

B= B+1}.

Program painter;

Uses Crt;

Const Pi=3.14;

Var R, S,S1,H,Ost : Real; Bool : Boolean; B: Integer;

Begin

ClrScr;

Write(‘ Радиус цилиндра>‘); Readln(R);

Write(‘Высота цилиндра>‘); Readln(H);

S1:= 236;

S:= 2*Pi*Sqr(R)+2*Pi*R*H;

B:=S DIV S1; Ost:= S - S1*B;

Bool:= Ost <> 0;

if Bool then B:=B+1;

Writeln(‘ необходимо купить ‘, B, ‘банок’);

readkey;

End.


Управление экраном в текстовом режиме

Управление экраном в текстовом режиме

Экран монитора в текстовом режиме имеет стандартное разрешение 80х25.

Возможность управления выводом на экран предоставляет стандартный модуль CRT.

Uses Crt; - подключение модуля к программе предоставляет доступ к его процедурам и функциям:

Window(x1,y1,x2,y 2); - задает текстовое окно.

TextBackGround(color);- устанавливает цвет фона.

TextColor(Color);- устанавливает цвет символа.

ClrScr;- очистить экран.

GotoXY(x,y);- перемещает курсов в позицию, заданную координатами

Readkey – считывает символ с клавиатуры.

Если к цвету символа добавить число 16, то текст будет мигающим.


Тест №3

Тест №3

1. Вычислить:

(15-3)/4*3

Ответ:

2. Какая разница между числами

20 и 2 Е +01?

Ответ: У этих чисел разный

3.

Запишите на языке программирования Pascal синус от х градусов. (синус вычисляется от аргумента в радианах)

Ответ:

4.

Вычислите:

Trunc (29.9) + Round (6.1)

Ответ:

5.

Вычислите:

Not (4<8) Or (3<1)

Ответ:

6.

Чему равно значение переменной х после выполнения последовательности действий?

x:= 2;

y:=x*x+2*x;

x:=x-y;

y:=x+y;

Ответ: x =

7. Присвоить переменной d первую цифру дробной части положительного вещественного числа x.

Ответ: d:=


Тест №4

Тест №4

1. Вычислить:

25+10*4/2*3

Ответ:

2.

Какая разница между числами

200 и 200.0?

Ответ: У этих чисел разный

3.

Пусть а – градусная мера угла. Запишите на языке программирования Pascal формулу перевода градусной меры в радианную.

Ответ:

4. Вычислите:

Trunc (1. 9) + sqrt (64)

Ответ:

5.

Вычислите:

(7=7) and (6<4)

Ответ:

6.

Чему равно значение переменной х после выполнения последовательности действий?

x:=5;

y:=x*2;

x:= y*y+y;

x:=x+y;

Ответ: x =

7.

Присвоить переменной d последнюю цифру целой части положительного вещественного числа y.

Ответ: d:=

Ваше имя:
Ваш e-mail:


Самоподготовка 2

Самоподготовка

Тема 3: "Форматы вывода"

И.Г. Семакин, А.П. Шестаков «Основы программирования», стр. 51-52

В.Б. Попов «Turbo Pascal для школьников», стр. 93-97

Курс по программированию на Паскале, раздел "Введение в Паскаль"

Вопросы:

  1. Как задается ширина поля вывода для целочисленных данных?
  2. Форматы вывода для вещественных данных.
  3. Можно ли применять форматы вывода для сипвольного и булевского типов данных?


Демонстрация

Демонстрация интегрированной среды Паскаль

НАЦИОНАЛЬНЫЙ ФОНД ПОДГОТОВКИ КАДРОВ. ИНФОРМАТИЗАЦИЯ СИСТЕМЫ ОБРАЗОВАНИЯ.
Сайт сделан по технологии "Конструктор школьных сайтов".


Занятие 3

Тема: "Линейная структура программы. Управление экраном в графическом режиме"

  1. Линейный алгоритм или следование
  2. Арифметический оператор присваивания
  3. Логический оператор присваивания
  4. Решение типовых задач
  5. Управление экраном в графическом режиме
  6. Тест №5 "Проверь себя"
    7.
  7. Самоподготовка


Линейный алгоритм

Линейный алгоритм

Линейный алгоритм или следование – это тип алгоритма, в котором последовательность действий не меняется в его процессе выполнения.

Предложение языка программирование задающее описание действия называется оператором. Операторы бывают простые и структурные.

Простыми называются операторы, которые описывают одно действие. Такие операторы используют для составления простейших линейных алгоритмов.

В программе линейный алгоритм реализуется последовательным размещением операторов.


Оператор присваивания

Арифметический оператор присваивания

Для вычислений с сохранением результата используют оператор присваивания.

Формат оператора:

<имя переменной>:=<арифметическое выражение>;

Способ применения оператора | Вид арифметического выражения | Пример
1. Присвоение переменной начального значение | число | a : = 2
2. Пересылка значения из одной переменной в другую. | переменная | a : = b
3. Вычисление ариф. выражения с сохранением результата. | арифметическое выражение общего вида | c : = a + b - 4


Логический оператор присваивания

Логический оператор присваивания

Формат оператора:

<имя переменной>:=<логическое выражение>;

Пример:

var a, b, c:Boolean;

…

b:= X>Y;

a:=false;

c:= a OR b;

…


Управление экраном в графическом режиме

Управление экраном в графическом режиме

  • Модуль Graph
  • Инициализация графического режима
  • Переключение режимов экрана
  • Графические процедуры


Модуль Graph

Модуль Graph

В графическом режиме стандартное разрешение экрана 640х480.

Модуль Graph – графическая библиотека.

Подключение модуля к программе предоставляет доступ к его процедурам и функциям:

Uses Graph;


Инициализация графического режима

Инициализация графического режима

По умолчанию при запуске программы инициализируется текстовый режим экрана, поэтому перед работой с графикой следует установить графический режим процедурой InitGraph.

Формат:

InitGraph(<драйвер>, <видеорежим>, <путь к драйверу>);

Пример:

Program FirstGraph;

uses Crt, Graph;

var DriverVar, ModeVar: integer;

begin

DriverVar:=Detect;

InitGraph(DriverVar, ModeVar,’’);

<операторы графики>

end.

Автоматическая инициализация графического режима с наиболее подходящим для монитора видеорежимом.


Графические процедуры

Графические процедуры

  • Вывод точки
  • Вывод линии
  • Построение прямоугольников
  • Построение окружности, эллипса, дуг и секторов
  • Построение ломаной линии
  • Работа с текстом


Решение задач

Решение задач

Задача1.

Поменять значения a и b местами (рассмотреть два случая).

1) использовать третью переменную;

2) без использования третьей переменной.

Задача2.

Выделить 1 и 3 цифры в записи трехзначного числа.

Использовать операции DIV и MOD.

Задача3.

Определить h - полное количество часов и m – полное количество минут, прошедших от начала суток до того момента, когда часовая стрелка повернулась на f градусов.


Логические выражения

Логические выражения

Логическим выражение называется выражение, операндами которого являются данные булевского типа, по отношению которых можно сказать истинны они или ложны.

Простейшим логическими выражениями являются логическая константа, логическая переменная, выражение отношения.

Выражение отношения называется словосочетание языка, в котором два выражения связаны знаком операции отношения.

Операции отношения.

название | равно | не равно | больше | меньше | больше или равно | меньше или равно | принадлежность
операции | = | <> | > | < | >= | <= | in

Сложные условия или логические выражения строятся из простейших путем применения логических операций и круглых скобок.

Логические операции.

Операция | Not | And | Or | Xor
Действие | Логическое отрицание | Логическое произведение | Логическое сложение | Исключающее ИЛИ

Таблицы истинности логических операций

0 - ложь, 1 - истина

A and B |  |  | A or B |  |  | A хor B |  |  |  |
А В | 0 | 1 | А В | 0 | 1 | А В | 0 | 1 | A | Not A
0 | 0 | 0 | 0 | 0 | 1 | 0 | 0 | 1 | 0 | 1
1 | 0 | 1 | 1 | 1 | 1 | 1 | 1 | 0 | 1 | 0


Самоподготовка 3

Самоподготовка

Тема 4: "Аппаратная и программная поддержка графики"

В.Б. Попов «Turbo Pascal для школьников», стр.367-371

Вопросы:

  1. За счет каких элементов компьютера обеспечивается аппаратная поддержка графики?

  2. Что такое видеоадаптер?

  3. Каково назначение графических драйверов?

Тема 5: "Коды цветов. Стили линий. Стили заливки"

И.Г.Семакин «Основы программирования», стр. 399-400


Переключение режимов экрана

Переключение режимов экрана

Program FirstGraph;

uses Crt, Graph;

var

DriverVar, ModeVar: integer;

begin

ClrScr ; writeln(‘Текстовый режим’);

<операторы>

DriverVar:=Detest;

InitGraph(DriverVar, ModeVar,’’);

<операторы графики>

RestoreCrtMode; {восстановить текстовый режим}

Writeln(‘Текстовый режим’);

<операторы>

SetGraphMode(ModeVar);{Вернуть графический режим}

<операторы гафики>;

ReadKey;

CloseGraph;

end.


Построение окружности, эллипса и их дуг

Построение окружности, эллипса, дуг и секторов

Circle(X,Y:integer; R:word);

Рисует окружность

X, Y – центр окружности

R – радиус

FillEllipse(X,Y:integer; xR, yR:word);

Рисует закрашенный эллипс.

X, Y – центр эллипса

xR – радиус по оси X,

yR – радиус по оси Y

Arc(X,Y:integer; StAngle, EndAngle, R: word);

Рисует дугу окружности.

X,Y – центр окружности

StAngle, EndAngle – начальный и конечный угол

R – радиус

Ellipse(X,Y:integer; StAngle, EndAngle, xR, yR:word);

Рисует эллипс и его дуги.

X, Y – центр эллипса

StAngle, EndAngle – начальный и конечный угол

xR – радиус по оси X,

yR – радиус по оси Y

Sector(X,Y:integer; StAngle,EndAngle, xR,yR:word);

Рисует закрашенный сектор

X,Y – центр эллипса

StAngle, EndAngle – начальный и конечный угол

xR – радиус по оси X

yR – радиус по оси Y

PieSlice(X,Y:integer; StAngle,EndAngle, R);

Рисует в окружности закрашенный сектор как в диаграмме


Вывод точки

Вывод точки

PutPixel(X,Y:integer; Color:word);

Выводит точку

X,Y – экранные координаты точки

Color – ее цвет


Вывод линии

Вывод линии

SetColor(color);

Задает цвет

сolor - код цвета

SetLineStyle(LnStyle:word; P:word; Thickness:word);

LnStyle стиль линии | P образец | Thickness толщина линии
 | (для стандартных стилей - 0) |

Line(X1,Y1,X2,Y2:integer);

Рисует линии

X1, Y1 – координаты первой точки

X2, Y2 – координаты первой точки

MoveTo (x,y)

Перемещение текущего указателя в точку с координатами (x,y)

LineTo (x,y)

Построение линии из точки текущего положения указаделя в точку с координатами (x,y)

LineRel (dx,dy)

Построение линии из точки текущего положения указаделя в точку, полученную смещением от точки текущего положения указателя на dx, dy


Построение прямоугольников

Построение прямоугольников

SetFillStyle(Pattern:word; Color:word);

Задает стиль заполнения

Pattern – образец заполнения

 Color – цвет заполнения

Bar (X1, Y1, X2, Y2:integer);

Рисует закрашенный прямоугольник

X1, Y1 – координаты левого угла

X2, Y2 – координаты правого нижнего угла

Bar3D (X1, Y1, X2, Y2:integer; Depth:Word; Top:boolean);

Рисует параллелепипед

X1, Y1 – координаты левого угла

X2, Y2 – координаты правого нижнего угла

Depth – глубина трехмерного контура

Top – определяет, строить ли верхнюю грань

да (true), нет (false)

Rectangle(X1,Y2,X2,Y2:integer);

Строит прямоугольник

X1,Y1 – координаты левого верхнего угла

X2,Y2 – координаты правого нижнего угла

FloodFill(X,Y:integer; Border:word);

Заполняет ограниченную область

X,Y – точка внутри контура

Border – цвет контура


Построение ломаной линии

Построение ломаной линии

Построение многоугольников, ломаных линий

NumPoints – задает число вершин

PolyPoints – массив, содержащий координаты вершин

Program Graph4; {Построение треугольника}

Uses Crt, Graph;

Var pp:array[1..4] of PointType;

i, DriverVar, ModeVar: integer;

Begin

DriverVar:=Detect;

InitGraph (DriverVar, ModeVar,’’);

for i:=1 to 3 do

begin pp[i].x:=Random(100);

pp[i].y:=Raddom(100)

end;

pp[4]:=pp[1];

SetColor(12);

DrawPoly(4, pp);

Readkey;

CloseGraph;

End.


Работа с текстом

Работа с текстом

OutTextXY(X,Y:integer; Textstring:string);

Выводит текст в заданной точке экрана

X,Y – экранные координаты точки

Textstring – символьная строка

SetTextStyle(Font:word, CharSize:word);

Font - тип шрифта | CharSize - размер шрифта

SetTextJustify(Horiz, Vert:word) ;

Выравнивание текста

Horiz-по горизонтали | Vert- по вертикали
0 - по левому краю 1 - по центру 2 - по правому краю | 0 - по нижней границн 1 - по центру 2 - по верхней границе


Тест №5

Тест №5

Ответы вводить строчными буквами!
1. Формат записи процедуры, выводящей закрашенный прямоугольник:(x1, y1, x2, y2);
2. Для построения окружности используют процедуру (x, y, R);
3. Строит параллепипед процедура (x1,y1,x2,y2,Depth,Top);
4. Процедура PieSlice(X,Y:integer; StAngle,EndAngle, R) строит в окружности .
5. Ломаную линию или многоугольник строит процедура (NumPoints:word; var PolyPoints);

6. | Дугу эллипса построит процедура ...
 | FillEllipse
 | Arc
 | Ellipse
 | PieSlice
7. | Для построения сектора недбходимо воспользоваться процедурой ...
 | Arc
 | Sector
 | PieSlice
 | Ellipse
8. | Какому параметру надо присвоить значение True, чтобы нарисовалась верхняя грань параллепипеды?
 | Depth
 | Top
 | Border
 | Pattern
9. | Укажите все параметры процедуры FloodFill
 | x
 | Border
 | Pattern
 | y
 | Depth
10. | Процедуру SetTextJustify используют для ...
 | установки шрифта
 | установки цвета
 | выравнивания текста
 | установки размера
 | установки палитры


Занятие 4

Тема: "Ветвление в программе"

  • Ветвление в алгоритмах
  • Условный оператор
  • Составной оператор
  • Оператор выбора
  • Решение типовых задач
  • Домашнее задание


Ветвление в алгоритмах

Ветвление в алгоритмах

Ветвление – это тип алгоритма, в процессе исполнения которого данные влияют на ход выполнения алгоритма; в алгоритме заложены различные пути следования, по ходу действия выбирается один из возможных вариантов.

Существует ветвление, в котором из 2-х альтернатив выбирают одну. Вот формы записи такого ветвления в блок-схемах. Такое ветвление в языках программирования реализуется условными операторами.

Для выбора из нескольких вариантов одного используют множественный выбор, который реализуется оператором выбора.


Условный оператор

Условный оператор

Теперь рассмотрим условный оператор.

Формат записи оператора:

IF B THEN A1 ELSE A2;

полная форма записи

IF B THEN A1;

неполная форма записи

Условный оператор образует сложноподчиненное предложение. Оно, во-первых, содержит после слова IF (ЕСЛИ) условие (В), во-вторых, после слова THEN стоит указание действия A1, которое должно выполняться при выполнении условия, и, в-третьих, после слова ELSE стоит указание действия A2, которое должна выполнить программа, если условие не выполняется.

Условием является логическое выражение.

Действием может быть простой или составной оператор.


Составной оператор

Составной оператор

Блок операторов, заключенный в операторные скобки называется составным. Формат записи:

Begin

<операторы>

end;

Например, вычисление квадратного корня из числа "a" проводится при условии a>=0, операторами:

IF a >= 0 Then

b:= Sqrt(a)

Else

begin

WriteLn ( 'a<0' ); Readkey; Halt

end;

Оператор Halt прекращает выполнение программы.


Оператор выбора

Оператор выбора

Если при решении задачи нужно выбирать одно действие из нескольких возможных, то используют, как сказано выше, множественный выбор. Для его реализации существует в PASCALе оператор выбора CASE.

Формат записи оператора:

Case < выражение-селектор> of

<Список 1>: A1 ;

…

<Список n>: An;

[ Else An+1 ]

end;

A1 , … , An+1 – простые или составные операторы.

Списки состоят из констант выбора (константа может быть одна).

Оператор Case работает так: сначала вычисляется значение выражения-селектор, затем оно сравнивается с каждым списком и при совпадении значений выполняется соответствующий оператор, если совпадения не произошло, то выполняется оператор, стоящий за словом Else. Выражение-селектор должно относиться либо к целочисленному, либо к булевскому, либо к символьному типу.


Решение типовых задач

Решение типовых задач и примеры программ

  • Задача 1. Нахождение максимального из двух чисел
  • Задача 2. Нахождение максимального из трех чисел
  • Пример 1. Контроль ввода данных
  • Пример 2
  • Пример 3


Задача 1

Задача 1

Найти максимальное из 2 чисел и присвоить его значение переменной m.

Математическая постановка задачи.

Исходные данные: a, b –любые числа.

Результат: m =max(a, b).

Метод решение задачи состоит в том, чтобы присвоить переменной m большее значение из a и b путем их сравнения.

Блок-схема

1 вариант решения задачи | 2 вариант решения задачи


Задача 2

Задача 2

Найти максимальное из трех чисел и присвоить его значение переменной m.

Математическая постановка задачи.

Исходные данные: a, b, c –любые числа.

Результат: m =max(a, b, c).

Метод решение задачи состоит в том, чтобы присвоить переменной m большее значение из a,b,c путем попарного их сравнения .

Блок-схема

1 вариант решения задачи | 2 вариант решения задачи


Пример 1

Пример 1. Защити программу паролем.

Пример программы, в которой считывается с клавиатуры символьный пароль Ch, если ввели N, то переменной Parol присваивается значение true, считывается числовой код X и проверяется равен ли он числу 100, если нет, то вывод сообщение об ошибке и прерывание программы Halt.

Program password;

uses crt;

var

ch:char; x:integer;

parol:boolean;

Begin

clrscr;

Write('Введите пароль:');Readln(ch);

if ch='N' then parol:=true else parol:=false;

if parol=true then

begin

Write('Введите код:');Readln(x);

if x=100 then Write('Пароль и код правильные')

else

begin

Writeln(‘SOS'); readkey; Halt;

end;

end;

readkey

end.


Пример 2

Пример 2. Определение порядка целого числа

Определение порядка целого числа N от 0 до 999:

PROGRAM ZNACH;

uses Crt;

var N: word;

Begin

Randomize;

N:=Random(1500);

case N of

0..9: writeln('однозначное');

10..99: writeln('двузначное');

100..999: writeln('трехзначное')

else writeln('Число', N, ' не входит в указанный диапазон')

end;


Пример 3

Пример 3. Случайное предсказание

Случайное предсказание одного из десяти вариантов ближайшего будущего с вероятностью 1/20, в остальных случаях - вы "неудачник".

PROGRAM FUTURE;

var N: word;

Begin

     writeln('ПРЕДСКАЗАНИЕ БУДУЩЕГО');

   Randomize;  N:=Random(20)+1;      { N - случайное число от 1 до 20 }

writeln; write('Вас ожидает _');

    case N of

1: writeln('счастье'); 6: writeln('здоровье');

2: writeln('пятерка'); 7: writeln('деньги');

3: writeln('дорога'); 8: writeln('любовь');

4: writeln('двойка'); 9: writeln('встреча');

5: writeln('болезнь'); 10: writeln('дети')

else writeln('неудача')

    end;

writeln('Нажми Enter'); readln;

end.


Занятие 5

Тема: "Разработка программ с ветвлением в алгоритмах"

  • Актуализация опорных знаний
  • Применение знаний и способов действий
  • Контроль знаний
  • Домашнее задание


Актуализация

Актуализация опорных знаний

  1. Вопросы для контроля знаний

  2. Устный счет
  3. Конструирование программы из готовых блоков
  4. Разбор выполненных заданий по карточкам


Вопросы

Вопросы

  1. Дайте определение алгоритму ВЕТВЛЕНИЕ.

  2. Какой оператор реализует выбор одной из двух предложенных альтернатив?
  3. Что называется логическим выражением?

  4. Что представляет из себя множественный выбор? И как он реализуется в Паскале?

  5. Как называется блок операторов, заключенный в операторные скобки?


Устный счет

Устный счет

1.

Какое значение напечатается, если ввести число 2?

program one;

var x,y:integer;

begin

read(x);

if x<0 then y := abs(x) else y := x + 1;

write(y);

end.

Ответ:

2. Какое значение напечатается, если ввести числа 1 и 5?

program one;

var x,y,z : integer;

begin

read(x, y); z := 1;

if (PRED(x)>7)and(SUCC(y)<6)

then z := z + SUCC(y) else z := z + PRED(x);

write(z);

end.

Ответ:

3.

Какое значение напечатается, если ввести число 6?

program one;

var x,z : integer;

begin

read(x);

if ODD(x) then z := x-1 else z := x+1;

write(z);

end.

Ответ:

4.

Какое значение напечатается, если ввести числа 1.862473 и 0.1262781?

program one;

var x,y : real; z : integer;

begin

read(x, y); z := 0;

if TRUNC(x)>ROUND(y) then if x*y>0

then z := 0 else z := z+1 else z := z+2;

write(z);

end.

Ответ:

5.

Какое значение напечатается, если ввести числа -1 и –1

program one;

var x,y,z : integer;

begin

read(x, y); z := (SQR(x)- y) * 3 - 10;

if z<0 then x := ABS(z + x) else

if x * y - 1 >0 then x := 7 else x := y;

write(x);

end.

Ответ:


Конструирование

Конструирование

Задача.

Определить и вывести на печать номер квадранта, в котором расположена точка М(x,y), x и y заданные вещественные числа.


Разбор

Разбор выполненных заданий по карточкам

Карточка №1

Определить, какая из двух точек M1(x1,y1) или M2(x2,y2) расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

Карточка №2

Определить, какая из двух фигур (круг или квадрат) имеет большую площадь. Известно, что сторона квадрата равна а, радиус круга r.


Применение

Применение знаний и способов действий

Задача 1.

Решение квадратного уравнения aх2+bх+с=0 . Составим словесный алгоритм решения этого уравнения. Учащимся раздаются карточки с блок-схемой и предлагается самостоятельно составить программу.

1. Определим значения а, в, с путем ввода с клавиатуры.

2. Вычислим D= b2 - 4а с

3. Если а =0 , то уравнение не является квадратным, иначе 4.

5. Конец.

Блок-схема

G Задачи для решения:

1. Составить программу, предлагающую отгадать загадку. Текст загадки печатается на экране, затем отгадывающий вводит ответ в символьную переменную, которая сравнивается с правильным ответом, хранящимся в другой символьной переменной.

2. Проверить, является ли число, введенное с клавиатуры кратным 5.

3. Составить программу, контролирующую 2-й закон Ньютона. Обучаемый вводит формулу закона Ньютона в символьную переменную, которая далее сравнивается с правильным ответом, хранящимся в другой символьной переменной.

4. Составить программу, определяющую проходит ли график функции y=5x2-3x+2 через точку (1; 2).

5. Даны два действительные числа x, y. Возвести в квадрат то из них, которое неотрицательно.

6. Даны действительные числа x, y, z. Вычислить максимальное значение из выражений x+y+z и xyz.


Тест №6

Тест №6

Начать тестирование


Домашнее задание

Домашнее задание

Задача 1.

Разработать блок-схему и составить программу для решения линейного уравнения ах+b=0


Занятие 6

Тема: "Циклический алгоритм. Операторы цикла"

  • Циклический алгоритм
  • Оператор цикла с параметром
  • Оператор цикла с постусловием
  • Оператор цикла с предусловием
  • Демонстрационные примеры


Циклический алгоритм

Циклический алгоритм

Цикл (повторение) – это тип алгоритма, в процессе выполнения которого одно или несколько действий нужно повторить несколько раз.

Выделяется ТРИ типа команды повторения! Цикл ДЛЯ, цикл ПОКА, цикл ДО.

Рассмотрим цикл ДЛЯ. Второе его название – это ЦИКЛ с параметром. Если повторяемые действия различаются некоторой величиной (параметром), то ее необходимо выделить и обозначить.

Циклы с условием - это циклы ПОКА и ДО.

Число повторений может быть переменным и зависеть от условия задачи. Поэтому в таком случае нельзя применить цикл с параметром, где число повторяющихся действий известно. От того, где будет находиться проверка условия перед телом цикла или после него, зависит название цикла. Если условие стоит до тела цикла, то это цикл с предусловием, если после, то с постусловием. Отличие этих циклов в том, что в первом тело цикла может не выполниться ни разу, а во втором выполнится хотя бы 1 раз. Это зависит от выполнения условия.


Оператор цикла с параметром

Оператор цикла с параметром

Формат оператора: Блок-схема оператора:

For i := N1 to N2 do A;

For i := N1 downto N2 do A;

Переменная i пробегает все значения от N1 до N2, при этом для каждого значения i выполняется тело цикла A, в случае to значение i увеличивается на 1, а в случае downto значение i уменьшается на 1.


Оператор цикла с предусловием

Оператор цикла с предусловием

Формат оператора: Блок-схема оператора:

While B do A;

Пока значение булевского выражения В TRUE (истинно) будет выполняться тело цикла A. Выражение В является условием выполнения цикла.


Оператор цикла с постусловием

Оператор цикла с постусловием

Формат оператора: Блок-схема оператора:

Repeat A until B;

Тело цикла A повторяется до тех пор, пока значение булевского выражения В не станет TRUE (истинно). Выражение В является условием завершения цикла.


Демонстрационные примеры

Демонстрационные примеры

  • Пример 1
  • Пример 2
  • Пример 3


Пример 1

Пример 1

Рассмотрим фрагмент программы:

for i:=1 to 20 do

writeln(‘МЯУ-МЯУ’);


Пример 2

Пример 2

Рассмотрим фрагмент программы:

i:=1;

while i<=20 do

begin

writeln(‘МЯУ-МЯУ’);

inc(i);

end;


Пример 3

Пример 3

Рассмотрим фрагмент программы:

i:=1;

repeat

writeln(‘МЯУ-МЯУ’);

inc(i);

until i>20;


Занятие 7

Тема: "Основные алгоритмы циклической структуры"

  • Накопление суммы
  • Нахождение наибольшего значения
  • Подсчет количества элементов по заданному признаку
  • Циклы и графика
  • Решение задач
  • Домашнее задание


Занятие 8

Тема: "Разработка программ циклической структуры"

  • Тестирование
  • Решение задач
  • Домашнее задание


Занятие 9

Контрольная работа

Вариант А

I

1. Одна сторона прямоугольника на 5 см. длиннее другой, а сумма их длин равна 17 см. Найти стороны этого прямоугольника.

2. Вводятся оценки по физике и математике. Вывести на экран "Молодец", если их сумма равна или более 8, в противном случае вывести "Учиться, учится и учиться".

3. В ответ на введенное число от 0 до 10 выдать сообщение четное это число или нет.

4. Написать алгоритм читающий "N" и выдающий на экран квадраты чисел от 1 до "N"

II

1. Нефтебаза отпустила за два дня 2560 л. бензина. Во второй день база отпустила на 280 л. больше. Сколько литров бензина база отпустила отдельно за каждый день?

2. Определите из двух девочек старшую по году рождения.

3. В ответ на введенное число от 0 до 10 выдать сообщение, кратно оно 7 или нет.

4. Ввести с клавиатуры 6 чисел. Найти их произведение.

Вариант B

I

1. В течение месяца продавец доставлял на дом 4 л молока в день. В марте молоко стоило х руб. за литр С первого апреля цена молока увеличилась на a руб. за литр Сколько надо заплатить продавцу за все доставленное молоко в конце апреля? Количество покупаемого молока осталось прежним.

2. Ввести с клавиатуры 2 числа. Напечатать их разность, вычитая из большего меньшее.

3. С клавиатуры вводится число (С=1 7), в ответ выводится название одного из цветов радуги.

II

1. Хозяин хочет оклеить обоями длинную стену в своем доме. Длина этой стены равна а и высота b. Рулон обоев имеет длину 12 м и ширину 1 м. Сколько будут стоить обои для всей стены если цена одного рулона k руб.

2. Задать с помощью генератора случайных чисел час суток - целое число от 0 до 23.Напечатать, к какой половине дня он относится (до или после полудня).

3. Задается с клавиатуры число от 1 до 3. Вывести числительное среднего рода.

Вариант C

I

1. Лена, Денис и Марина живут на одной и той же улице, где находится школа. Лена живет на расстоянии 2/5 от школы до дома, где живет Денис. Денис живет на расстоянии 4/5км от школы, Марина живет посередине между Леной и Денисом. На каком расстоянии от школы находится дом Марины?

2. Составить программу, определяющую, входит ли введенная Вами цифра в запись введенного трёхзначного числа, и печатающую сообщение о том, входит ли эта цифра в запись числа или нет.

3. В поликлинике кабинеты распределены так: 1, 2, 3, 17 - окулисты; 4, 18, 19, 20 - хирурги; 5 - 8 - стоматологи; 9 - 16 - педиатры. Задать с помощью генератора случайных чисел № кабинета - целое число от 1 до 20, определить специальность врача.

4. Задать случайным образом 12 чисел от 22 до 325. Напечатать те из них, которые попадают в промежуток от 60 до 100.

II

  1. Купец купил 138 аршин черного и синего сукна за 540 рублей. Спрашивается, сколько он купил того и другого, если синее стоило 5 рублей за аршин, а черное - 3 рубля.

  2. Составьте алгоритм и программу, выбирающую из трех чисел то, которое лежит между двумя другими.

  3. Задать с помощью генератора случайных чисел № ряда в кинотеатре - целое число от 1 до 25. Определить, сколько стоит билет, если его цена зависит от ряда: 1, 2, 3, 25 - 50 руб.; 4, 5 - 60 руб.; с 6 по 24 - 70 руб.

  4. Ввести с клавиатуры номер лотерейного билета. Задать случайным образом 16 целых чисел от 1 до 1000 - номера выигравших билетов. Напечатать, выиграл ли купленный билет.


Накопление

Накопление суммы

Найти S сумму N введенных с клавиатуры чисел.

Математическая постановка задачи:

  1. Исходные данные:

N – количество чисел

а – переменная для обозначения вводимых чисел.

  2. Результат:

S – сумма чисел.

  3. Метод решения задачи:

Составляем рекуррентное соотношение:

Sk=Sk-1+a, S0=0,

Используя его, делаем последовательное суммирование, начиная с k=1 и до k=N.

Задача.

Ввести N, ввести N чисел. Выбрать большее.

Математическая постановка задачи:

1. Исходные данные:

N – количество чисел

а – переменная для обозначения вводимых чисел.

2. Результат:

max – большее из чисел.

3. Метод решения задачи:

Сравнивая предыдущее и текущее число, выбираем большее, перебирая все числа.


Нахождение максимального

Нахождение наибольшего значения

Ввести N, ввести N чисел. Выбрать большее.

Математическая постановка задачи:

1. Исходные данные:

N – количество чисел

а – переменная для обозначения вводимых чисел.

2. Результат:

max – большее из чисел.

3. Метод решения задачи:

Сравнивая предыдущее и текущее число, выбираем большее, перебирая все числа.


Подсчет количества элементов по заданному признаку

Подсчет количества элементов по заданному признаку

Даны n чисел, введенных с клавиатуры. Подсчитать количество кратных 3 положительных чисел.


Циклы и графика

Циклы и графика

Задача1.

Построить n окружностей заданного радиуса по горизонтали. Число n задать случайным образом.

Задача2.

Построить n окружностей заданного радиуса по диагонали. Число n задать случайным образом.

.


Домашнее задание

Домашнее задание

  1. Найти меньшее значение.

  2. Построить n окружностей заданного радиуса по вертикали. Число n задать случайным образом.


Решение задач

Решение задач

  1. Требуется найти значения функции y=x2-3x-7 при изменении аргумента от -10 до 10.
  2. Необходимо сложить все четные числа от 2 до 20.
  3. Необходимо подсчитать произведение нечетных чисел от 1 до 15.


Решение задач

Решение задач

Задача 1.

Посчитать количество цифр в числе N.

Задача 2.

Пассажирский самолет может поднять груз общим весом 30 тонн. Составить программу, для определения веса почтового груза, который можно поместить в самолет после посадки пассажиров и загрузки их багажа. Во время регистрации необходимо посчитать количество пассажиров и суммировать вес багажа (условный вес пассажира = 100 кг).

Задача 3.

Одноклеточня амеба каждые 3 часа делится на 2 клетки. Определить сколько клеток будет через 3, 6, 9, 12, ... ,24 часа.

Задача 4.

Начав тренировки , спортсмен в первый день пробежал 10км.Каждый следующий день он увеличивал дневную норму на 10% от нормы предыдущего дня. Какой суммарный путь пробежит спортсмен за 7 дней.


Домашнее задание

Домашнее задание

Задача 1.

В 1985 году урожай ячменя составил 20ц с 1га. В среднем каждые два годаза счет применения передовых агротехнических приемов урожайность увеличивается на 5%. Определить через сколько лет урожайность достигнет 25ц с 1га.

Задача 2.

В компьютер вводятся фамилии спортсменов и их результаты в соревнованиях по прыжкам в длину. Число участников произвольно. Выдать на печать лучший результат после выступления, т.е. выдать итоговое сообщение о победителе


Домашнее задание

Домашнее задание

Разработать блок-схему и составить программу для решения линейного уравнения ах+b=0. Рассмотреть все возможные случаи решения уравнения.


Домашнее задание

Домашнее задание

НАЦИОНАЛЬНЫЙ ФОНД ПОДГОТОВКИ КАДРОВ. ИНФОРМАТИЗАЦИЯ СИСТЕМЫ ОБРАЗОВАНИЯ.
Сайт сделан по технологии "Конструктор школьных сайтов".


Тестирование

Тестирование

Начать тестирование


Отправка почтового сообщения

ФИО
Ваша эл. почта